Weekly Links Roundup – Hacked Sites, Easy WP Guide, Event Calender Plugins, PHP Versions

This week’s top WordPress and web marketing links.

If your WordPress site had been hacked, how would you know? Check out this infographic from iThemes showing 7 key signs that your site has been the target of a hack. Prevention is much easier than recovery – if you need help keeping your site secure, check out our WordPress maintenance plans. We include an upfront (and then annual) security audit of your site in all our plans.

Easy WP Guide has just released their new guide for WordPress 5.1 – get a PDF here. But don’t bother to print it, it gets updated frequently and is quite large!

Looking for an event calendar for your site? Here’s a roundup of 5 event calendar plugins for WordPress. This list is unusual in that it doesn’t include some of the big players in the category – these are all commercial plugins available at Code Canyon. Check out this post for some top free event calendar plugins – lots of high-quality choices listed here.

A common problem I see with new WP Minder clients is old PHP versions. Why is this so important? WordPress now recommends a minimum of PHP 7.3. But over 77% of WordPress users are on unsupported (read: no security updates ever) versions of PHP – that’s PHP 7.0 and older! Most users don’t know or care about this, but here’s why you should.

You can check the PHP version with this plugin.

WP Minder’s maintenance plans include fast Managed WordPress Hosting on modern, up-to-date servers. Besides the security benefits our clients also get the performance boost that PHP 7.1+ provides.


Did you find this information useful? Please share with your friends and colleagues! And comment below with questions or observations.

Leave a Reply

Your email address will not be published. Required fields are marked *