Why Do I Need to Upgrade to PHP 7.1+?

Depending on your host, you may have gotten a rude surprise recently when you tried to update WordPress and got this message:

You cannot update because WordPress 5.2 requires PHP version 5.6.20 or higher. You are running version 5.6.3.

That’s right. Unless you’re running the (extremely old and unsupported) PHP 5.6.20 or greater, you won’t be able to update WordPress again. Ever.

Ideally, your host should be using PHP 7.1+ which is much, much faster than the old 5.x versions, as well as being actively maintained (7.1 and higher get security and other updates regularly).

WordPress is trying to nudge users to move to new versions of PHP for these two main reasons. In addition to not being able to update WordPress, if you’re on old PHP you will also not be able to install themes and plugins that don’t support your version of PHP. Plugins or themes may simple stop working correctly on the older, unsupported PHP versions.

So what can you do?

If you’re on a good host, you won’t have this problem as they will be keeping up with PHP updates or, like SiteGround, will offer you options on which version of PHP to use for your site.

If you’re on a bad host, you’ll find out quickly enough if you ask them to update PHP and they won’t. That means it’s time to move to a good WordPress host. There really is no other option – ask us if you need help choosing a good, high-quality WordPress host.

If you have the option to switch yourself, not so fast… there is a considerable amount of prep you need to do on your site before flipping the switch. Read this guide on how to upgrade WordPress to PHP 7 to understand what’s involved in doing this without breaking your site.


Did you find this information useful? Please share with your friends and colleagues! And comment below with questions or observations.

Leave a Reply

Your email address will not be published. Required fields are marked *